Mac OS X 10.8 on MacBook Air 11インチ – dfとamavisdとMail::SpamAssassin

もともと、256GBフラッシュストレージが内蔵されていた。
512GBのそれと入れ替えてしまったのだな。がはは。
本体くらいの値段がかかってしまったっっっっっ

で。

いろいろと入れてしまったのです。
はい、キリがありません。

結局、外付けの512GBHDDにファイルを持つことにしまして、ね。

dfコマンドで表示させると、容量が増えていないのですな。

Filesystem      Size   Used  Avail Capacity  iused    ifree %iused  Mounted on
/dev/disk0s2 446Gi  376Gi   70Gi    85% 98748456 18254526   84%   /

Finderで情報を見ると、予測通りに増えています。なんでしょうねぇ…

それよりも気になるのが、clamd, amavisdの導入。
ここしばらく、サーバーたちに導入していたのですけど、ね。こいつにも導入しないといけない。
作業して行くと、まず、postfixのmain.cfに変な記述が…

# grep Library main.cf
queue_directory = /Library/Server/Mail/Data/spool
data_directory = /Library/Server/Mail/Data/mtaServer.appを導入しているわけではないので、そもそも、このようなフォルダは存在していない。むむむむむ。妻が使っているMacBook Proのmain.cfの記述を追加して、「元に戻す」。

main.cfを、サーバーからコピーしたか?
記憶が曖昧です。あはははは。動いたから、いいことにする。

問題は、amavisdであります。
Mail-SpamAssassinが導入できないのです。
/usr/local/bin/perl(5.16)を使っていて、make testの段階で、

t/re_base_extraction.t ………… 1/128 Filehandle STDIN reopened as OUT only for output at t/re_base_extraction.t line 464.
Filehandle STDIN reopened as OUT only for output at t/re_base_extraction.t line 464.
などと表示されてしまいます。
ググると、
https://rt.perl.org/rt3/Public/Bug/Display.html?id=23838

Perlの問題らしい。むむむむむ。どうしようもないではないか…ここ、
https://github.com/renormalist/Mail-SpamAssassin-3.3.2-PerlFormance/commit/5e3bcb5e09dd45b32698c8c32f39da8a37215480
に、パッチが出ていた。
これを当てるの?
嫌だな〜〜〜気を取り直して…MacBook Airを再起動して、ログインし直して、make cleanしてやり直し。
/usr/bin/perl(5.12)を使ってみると…

ん?

出ないぞ?

その代わり、

t/config_tree_recurse.t ……….. Insecure directory in $ENV{PATH} while running with -T switch at SATest.pm line 206.
t/config_tree_recurse.t ……….. Dubious, test returned 255 (wstat 65280, 0xff00)
と、来ましたっっっっっむむむむむむむむむっ整理っ
使用するPerlのバージョンは、5.12、/usr/bin/perl
makeするのは、「わたし」
問題のスクリプトは、t/config_tree_recurse.t
で、このt/config_tree_recurse.t の1行目に、
#!/usr/bin/perl -T
と書かれていて、「『汚染』チェックをオン」にしているそうな…
http://perldoc.jp/docs/perl/5.8.4/perlrun.pod
http://perldoc.jp/docs/perl/5.16.1/perlsec.podで、まぁ、この1行目を
#!/usr/bin/perl -w
と、オプションを変えるとエラー無しになることはわかった。

けど、さ。
わたしの自宅マシンでは、こんなエラーは出なかったのだなぁ。

「とりあえず」今日はこのまま導入してしまおうか…気になるが…



うわっ

(!)_DIE: Su
icide () TROUBLE in pre_loop_hook: config: no rules were found!  Do you need to

run ‘sa-update’?

amavisdが自殺しましたっ

sa-updateについては、既に書いてあったな。

これで大丈夫だろう。


コメントを残す